Page 1 of 2

Configuration with VMPK

Posted: Fri Aug 07, 2020 2:09 pm
by cuppajoeman
Hi everyone, I was excited to get started on giada, but hit it a couple speed bumps.

I want to use vpmk as an input device to giada, here's what I've done:

Enabled global midi input

Configured sound:

Configured midi:

Then I tried recording by adding a midi channel, here I am trying to getting it to work:

anyways, I've been having trouble with it and so if anyone has any ideas let me know!

Re: Configuration with VMPK

Posted: Fri Aug 07, 2020 4:19 pm
by FFT
Hey cuppajoeman, from the video you posted it seems you didn't start a recording session. According to the user manual:

On MIDI channels you can record any type of MIDI event supported by the Piano Roll Editor. First of all press the arm button, then enable the action recording mode and start your performance with your MIDI controller. When you're done, disable the action recording mode by clicking on the record actions button a second time. ... ng-actions

Does it help?

Re: Configuration with VMPK

Posted: Sat Aug 08, 2020 10:33 pm
by cuppajoeman
Hi FFT, thanks for your quick response, I took a look through the docs and tried again using the recording session for midi actions, but still wasn't able to capture any of the input:

thanks in advance

Re: Configuration with VMPK

Posted: Sun Aug 09, 2020 6:55 pm
by mctom
It seems that your virtual piano has channel 4 set. This must be set to the same channel as in Midi Input Setup screen, and I assume there is "1" set, as default.

This is a MIDI standard feature that might be useful if you plan to use the same controller on multiple MIDI channels in Giada. By switching between channels in your controller, you are able to play different different channels in Giada.

Don't give up, try again. :)

And hopefully we will see MIDI channels in Giada support all incoming notes to avoid such confusion in the future..

Re: Configuration with VMPK

Posted: Mon Aug 10, 2020 8:40 pm
by cuppajoeman
Hey everyone. I was going to try mctom's comment but I started noticing something weird, whenever I went to the midi input section and tried to change the input device to vmpk, I get the following errors:

Code: Select all

[init] Giada 0.16.4
[init] Build date: Aug 10 2020
[init] Dependencies:
[init]   FLTK - 1.3.5
[init]   RtAudio - 5.1.0
[init]   RtMidi - 4.0.0
[init]   Libsamplerate
[init]   Libsndfile - libsndfile-1.0.28
[init]   JSON for modern C++ - 3.9.0
[init]   JUCE - 5.3.2
[midiMapConf::init] scanning midimaps directory '/home/cuppajoeman/.giada/midimaps/'...
[midiMapConf::init] unable to scan midimaps directory!

RtApiAlsa::getDeviceInfo: snd_pcm_open error for device (hw:2,0), Device or resource busy.

RtApiAlsa::getDeviceInfo: snd_pcm_open error for device (hw:2,0), Device or resource busy.

MidiInAlsa::getPortName: error looking for port name!

MidiInAlsa::openPort: the 'portNumber' argument (2) is invalid.

RtApiAlsa::getDeviceInfo: snd_pcm_open error for device (hw:2,0), Device or resource busy.

RtApiAlsa::getDeviceInfo: snd_pcm_open error for device (hw:2,0), Device or resource busy.

RtApiAlsa::getDeviceInfo: snd_pcm_open error for device (hw:2,0), Device or resource busy.

RtApiAlsa::getDeviceInfo: snd_pcm_open error for device (hw:2,0), Device or resource busy.

terminate called after throwing an instance of 'std::out_of_range'
  what():  vector::_M_range_check: __n (which is 18446744073709551615) >= this->size() (which is 0)
fish: “giada” terminated by signal SIGABRT (Abort)

I think it has to do with the initial port error, but other than that I'm clueless, if you have any ideas please let me know!

Re: Configuration with VMPK

Posted: Tue Aug 11, 2020 4:19 am
by cuppajoeman
Ok, so after alot of messing about I found this issue on github, which is similar:, but I haven't been able to solve the issue for myself, so instead I downloaded an AppImage version of giada, which doesn't seem to be having all these issues. And back to your suggestion mctom, here is what occurs when I tried your suggestion:

so it's still not working for me, hopefully I can get it to work soon!

Re: Configuration with VMPK

Posted: Tue Aug 11, 2020 8:02 am
by mctom
Hi there!

I'm sorry to hear you have the hard time to set up Giada and I'm really glad you didn't give up! :)

About the errors, thank you for reporting, as far as I know nobody has encountered it while configuring midi inputs and outputs. If you could post your case on GitHub in the issue section that you found yourself, it might be useful to solve the problem in the future. Thanks!

As of your trouble recording notes, everything you do seems to be in order. I believe that you might have recorded some notes. However, you missed one scroll bar in Action Editor window. If you stop your video at 1:05, you can clearly see there are actually two scroll bars - one for midi notes surface, and another one for the whole window. You did scroll the latter, but the first one remained in its uppermost positions, showing only the high pitch end of the available range. Try searching for your notes using the appropriate scroll bar! :)

I know this interface needs some work to make it easier to use, and this is also something on a roadmap:

Re: Configuration with VMPK

Posted: Wed Aug 12, 2020 2:04 am
by cuppajoeman
Hi mctom,

So I tried scrolling the first midi bar, to see if there were any notes from the lower keys to no avail:

So I suppose there is an issue with the midi connection... I'm not too sure what to try next, I guess I'll make an issue detailing everything that happened and what I tried at some point on the github issues.

Thanks for all your help up to date

Re: Configuration with VMPK

Posted: Wed Aug 12, 2020 9:15 am
by mctom
Hello cuppajoeman,

I recreated your steps, even downloaded VMPK for that. I did a little investigation and I think I have found the root of your problem.

There are three major sound systems for Linux: ALSA, PulseAudio and Jack. PulseAudio is the default one on most Linux systems, for example Firefox supports only that. Both PulseAudio and Jack use ALSA as its backend as default, so you might say it's a low-level interface to your sound gear.

The errors you're getting indicate that ALSA is busy serving something else - I can recreate that by playing some youtube music on Firefox and starting Giada Appimage. ALSA might be busy serving some other process that acquired it, even if it's not playing sounds at a time.
When I recreated your errors, notes are indeed not recorded at all. I'm not sure if that's a bug or not, because ALSA clearly states that it's not working properly. Nevertheless I'll post it on GitHub, because it's not clear to me whether ALSA MIDI and ALSA Sound should be interdependent.

Anyway, I think your solution would be to change sound system to either PulseAudio or Jack.
PulseAudio is best for casual use and most probably already running on your system, but might result in high latencies and incompatibility with many other Linux audio production software. Jack is de facto a standard for these things, with its advanced configuration features and patchbay capabilities. Both subsystems MAY work together, using PulseAudio bridging, but that's advanced stuff and you'd be better off installing Ubuntu Studio that does all that for you (using Ubuntu Studio Controls).
Using ALSA Sound directly is a very rare case.

If all I just wrote sounds new to you, go with PulseAudio and see if your problem persists. From my quick experiment it seems that it should not be a case anymore.

Re: Configuration with VMPK

Posted: Thu Aug 13, 2020 5:53 pm
by cuppajoeman
Hi mctom,

Thank you so much for putting effort into that!

I believe I am using pulseaudio (I use the pulsermixer cli tool to change the volume of programs on my computer).

I changed my soundsystem to pulseaudio in the main configuration settings, and noticed that there wasn't such an option for pulseaudio in the midi section (only jack and ALSA), so I continued with ALSA on that setting (I wasn't seeing the errors when it starts up so that looked good. But still no recording...

Not sure if I'm missing something, but I know we're close!

And thank you for your information about the different sound systems.